Reports: Analyzing, Printing, and Sharing Your Data

The reporting features in Diabetes Pilot allow you to review and analyze your data, send it to your doctor, archive it for safekeeping, and transfer it to other programs.

To access the reporting features, click the "Reports" icon on the toolbar.

Creating Reports

Using your Reports

Creating Reports

Creating a report in Diabetes Pilot is an easy three step process:

Step 1: Choose a Report

Select the report you would like to create from the list near the upper left corner of the Diabetes Pilot window. There are several reports to choose from:

  • Recent Glucose Averages - Shows your average glucose for various time periods and your current estimated A1C.
  • Logbook by Category - Shows your records in a "logbook" grid format organized by category
  • Logbook by Time - Shows your records in a logbook format in a flexible grid organized by time
  • Record Listing - Lists your records in a manner similar to how they appear on the My Records page.
  • Record Graph - Graphs your individual glucose readings, food, and medication over time
  • Average BG by Category - Shows your average glucose organized by category
  • Average BG by Hour - Shows your average glucose as an average for each hour of the day
  • Average BG by Month - Shows your average glucose by month
  • Glucose Ranges - Shows the number of glucose measurements in your target range, above your "high" limit, and below your "low" limit. These ranges can be set in the preferences window (seeSetting Preferences for more information)
  • Glucose Ranges by Category - Shows the number of glucose measurements in your target range, above your "high" limit, and below your "low" limit for each individual category.
  • Daily Food Totals - Summarizes food intake by day
  • Meal Listing - Provides a detailed list of your meal records
  • Medication Totals by Day - Shows a total of the medications you've entered for each day
  • Exercise Totals by Day - Shows a total of the exercises you've entered for each day
  • Blood Pressure Graph - Graphs your blood pressure readings
  • Weight Graph - Graphs your weight over time
  • CSV Record Export - Creates a plain text "comma separated values" file that contains your record data.   This is useful for importing your data into other programs (such as spreadsheets) that can read these types of files directly.  When you use this report, you'll be prompted for a file to save the data to, rather than having it displayed on the screen.
  • CSV Meal Export - Like the CSV Record Export, this report creates a plain text "comma separated values" file that contains your meal details.  

Step 2: Choose Records

Next, choose the records that you would like in the report using the filter controls (see Display Filters for more information). Or, click the "Show All Records" button to include all of your records.

Note that if your filters do not allow any records to be selected, the report will be blank - if this happens, change the filter settings to select the dates, categories, and record types that you want to include.

Also, note that some filter settings may not apply to certain types of reports and will be ignored.  For example, the "Recent Glucose Averages" report will always show your recent averages (and ignore the date filter) and the "Medication Totals" report will always show medication records (ignoring the record type filter).

The filter controls provide for numerous report possibilities.   For example, if you want a listing of your blood pressure readings, create a "Record Listing" report and select only the "BP" record type.   

Step 3: Create the Report

Click the "Create Report" button to create the report. Your records will be processed and the report will be displayed in a few moments.

Viewing the Report

  • Many reports will be more than one screenful - use the scroll bars as necessary to see the whole report.
  • Choose "File->Print" from the menu to print the report.

Using Your Reports 

In addition to viewing your reports on-screen in Diabetes Pilot, there are various ways to use your reports outside of the program.   First, create a report.  Then:

Printing a Report

  • Choose "File->Print" from the menu to print the report.

Saving a Report as a PDF

Saving your report as a PDF allows it to be read without needing Diabetes Pilot

  • Choose "File->Print" from the menu.
  • In the "Print" window, click the "PDF" button and choose "Save as PDF".

Emailing a Report 

This allows you to email your report to your doctor or whomever you choose.  The report is send as a PDF, which allows the recipient to read it without needing Diabetes Pilot themselves.

  • Choose "File->Print" from the menu.
  • In the "Print" window, click the "PDF" button and choose "Mail PDF".
Copying a Report
You can copy and paste information from the report.  This lets you paste it into a word processor, spreadsheet or wherever you choose:
  • Highlight the part of the report you'd like to copy by clicking-and-dragging on it.   Alternately, click on the report and type Command-A (or use the "Edit->Select All" menu item) to select the whole report.
  • Copy the report by typing Command-C (or use the "Edit->Copy" menu item) to copy the text
  • Paste the copied information into another program.